SDL on Mac not working when trying to run from LGM instead of emake

Reporter: time-killer-games  |  Status: open  |  Last Modified: July 28, 2018, 04:08:20 PM

SDL on Mac when running from LGM produces the following errors in the compile form:

https://pastebin.com/eAhESkw8

Doesn't happen when building with emake. But emake currently can't handle very large projects like LGM can, which is a different bug of its own but not the focus of this ticket.

Seems to be an issue with mouse, cursor, and window related functions.

RobertBColton  
This must be Mac specific because I can use it fine over here on Windows.

if (keyboard_check(ord('1'))) {
	window_mouse_set(0, 0);
}
if (keyboard_check(ord('2'))) {
	display_mouse_set(0, 0);
}

Do those functions work in GM on Mac? Further, your log contains all sorts of undefined references to the SDL functions, how are you even getting a window open? It seems this issue title is misleading and should be "can't use SDL on Mac at all" or something.

time-killer-games  

Yes I assume those functions work in GM4Mac and GMStudio. The window doesn't open. The game won't even run. I looked at the undefined references to those window, mouse, and cursor functions and it seems all of those are what's broken and why the game won't run.

These errors don't happen when running from emake; only happens when running from LGM.

RobertBColton  

Understood, I totally wouldn't have guessed that, so thank you very much for clarifying. I'll maybe try to help you guys look into this. I'm assuming you've already tried #1294 and that does not fix it?
time-killer-games  

Yes, that is the branch I pulled from. It didn't fix these errors. These errors I get from that branch. I don't know what would happen if I pulled from master because I haven't tried that; fundies said it didn't work in master.
Please sign in to post comments, or you can view this issue on GitHub.