Pages: « 1 2
  Print  
Author Topic: Can't open egm project on Linux [SOLVED]  (Read 4461 times)
Offline (Male) HitCoder
Reply #15 Posted on: February 12, 2015, 05:38:23 PM

Member
Location: King's Lynn, England
Joined: Aug 2014
Posts: 151

View Profile WWW Email
If anyone ever makes an IDE, then make it use tabs instead of scattered windows like that of gamemaker.

Also, thank you ExDeus, I will use that if it works.

EDIT: I am getting the exact same error as before.

EDIT2: I copied the jars from the version I use on windows into the one I built on Linux, it appears to be working perfectly so far...

EDIT3: I got this error upon compiling/testing "Line 9, position 13 (absolute 485): Invalid assignment to function `time'"
It works fine in windows :/

EDIT4: I changed the variable because it may be a conflict, so far so good though, so yeah....
« Last Edit: February 12, 2015, 06:04:12 PM by HitCoder » Logged
DISCORD: HitCoder#4530
hi my name is John Cooper and i'm not good at anything
Offline (Unknown gender) TheExDeus
Reply #16 Posted on: February 12, 2015, 06:41:04 PM

Developer
Joined: Apr 2008
Posts: 1872

View Profile
Yeah, "time" is probably taken. We already made everything to be in enigma_user:: namespace, but for some reason POSIX C functions keep polluting it. But it is weird that your Windows version worked, but my didn't. It's possible that some Linux regression has happened before Windows one.

Also, is Robert dead?
Logged
Offline (Male) HitCoder
Reply #17 Posted on: February 13, 2015, 07:30:36 PM

Member
Location: King's Lynn, England
Joined: Aug 2014
Posts: 151

View Profile WWW Email
I still got an error, it took so long to report it though, I didn't bother updating the post because I was too tired, but yea. - Also, I lost the log, but I couldn't find anything that explained it, but in the terminal it literally just printed '3' at the end, no other info. In the compiler dialouge, it just said failed to compile...

Also, I hope he's not, he's been really helpful, we can't afford to lose him!
« Last Edit: February 13, 2015, 07:32:15 PM by HitCoder » Logged
DISCORD: HitCoder#4530
hi my name is John Cooper and i'm not good at anything
Offline (Male) HitCoder
Reply #18 Posted on: March 29, 2015, 08:51:20 AM

Member
Location: King's Lynn, England
Joined: Aug 2014
Posts: 151

View Profile WWW Email
Okay, so I don't mean to bump this, but I have not got anywhere, here's the output for the last few lines of the compiler log: http://pastebin.com/1FEhkceF
And here's the same from the Terminal
Code: [Select]
Writing local accessors
Writing font data
Writing room data
Writing shader data
Running make from `make'
Full command line: make Game WORKDIR="/home/hitcoder/.enigma/" GMODE=Run GRAPHICS=OpenGL1 AUDIO=OpenAL COLLISION=Precise WIDGETS=None NETWORKING=None PLATFORM=xlib CXX=g++ CC=gcc CXXFLAGS="-std=c++11" COMPILEPATH="Linux/Linux" EXTENSIONS=" Universal_System/Extensions/Alarms Universal_System/Extensions/Timelines Universal_System/Extensions/Paths Universal_System/Extensions/MotionPlanning Universal_System/Extensions/DateTime Universal_System/Extensions/ParticleSystems Universal_System/Extensions/DataStructures" OUTPUTNAME="/tmp/egm8595916109687287675.tmp" eTCpath=""


*********** EXECUTE
  `/usr/bin/make`
  `Game`
  `WORKDIR=/home/hitcoder/.enigma/`
  `GMODE=Run`
  `GRAPHICS=OpenGL1`
  `AUDIO=OpenAL`
  `COLLISION=Precise`
  `WIDGETS=None`
  `NETWORKING=None`
  `PLATFORM=xlib`
  `CXX=g++`
  `CC=gcc`
  `CXXFLAGS=-std=c++11`
  `COMPILEPATH=Linux/Linux`
  `EXTENSIONS= Universal_System/Extensions/Alarms Universal_System/Extensions/Timelines Universal_System/Extensions/Paths Universal_System/Extensions/MotionPlanning Universal_System/Extensions/DateTime Universal_System/Extensions/ParticleSystems Universal_System/Extensions/DataStructures`
  `OUTPUTNAME=/tmp/egm8595916109687287675.tmp`
  `eTCpath=`



3

EDIT: It works with no issues at all on windows, but it appears to be something to do with the ini functions. Would this be because Linux does not support ini files?
If it is, how do I store settings??

EDIT2: Okay, I'm pretty sure that's the problem, INI files are obviously a windows thing, and Linux doesn't use them. Looks like Linux users will not be able to save their settings for now :/
« Last Edit: March 29, 2015, 08:54:20 AM by HitCoder » Logged
DISCORD: HitCoder#4530
hi my name is John Cooper and i'm not good at anything
Offline (Unknown gender) TheExDeus
Reply #19 Posted on: March 29, 2015, 12:35:53 PM

Developer
Joined: Apr 2008
Posts: 1872

View Profile
ENIGMA on Linux has a special Ini extension, so you can use ini's on Linux. You just probably have to enable it on Linux (and disable on Windows).

But this problem is unrelated to the EGM project not opening correct (the original topic)?
Logged
Offline (Male) HitCoder
Reply #20 Posted on: March 29, 2015, 02:40:45 PM

Member
Location: King's Lynn, England
Joined: Aug 2014
Posts: 151

View Profile WWW Email
Yes.. sorry for straying off topic, but aside from that, I had an issue on Linux and still couldn't run my game on Linux, to technically the issue was not fixed. I apologise for going off topic, however I didn't see a need for creating a new thread (I have created enough of those here already that are ongoing right now)
Logged
DISCORD: HitCoder#4530
hi my name is John Cooper and i'm not good at anything
Offline (Unknown gender) TheExDeus
Reply #21 Posted on: March 29, 2015, 05:36:16 PM

Developer
Joined: Apr 2008
Posts: 1872

View Profile
So does enabling the ini extension fix your problem on Linux?
Logged
Offline (Male) HitCoder
Reply #22 Posted on: March 30, 2015, 08:03:48 AM

Member
Location: King's Lynn, England
Joined: Aug 2014
Posts: 151

View Profile WWW Email
Yes, it does. Sorry for forgetting to include that in my last message. Thanks for all the help. ^^
Logged
DISCORD: HitCoder#4530
hi my name is John Cooper and i'm not good at anything
Pages: « 1 2
  Print