Pages: 1
  Print  
Author Topic: after i call game_end game process stuck  (Read 1380 times)
Offline (Unknown gender) qwerty
Posted on: January 18, 2015, 11:15:30 AM
Member
Joined: Jan 2015
Posts: 14

View Profile
if i create void proj, add game_end to an obj and run, gam retur 0 and process closes
but after next compil gam hides but its process still exists ???
Logged
Offline (Male) Goombert
Reply #1 Posted on: January 18, 2015, 06:35:02 PM

Developer
Location: Cappuccino, CA
Joined: Jan 2013
Posts: 3107

View Profile
Hello qwerty, do you know how to run the game in GDB? That would be extremely useful I fixed bugs before regarding game_end however I have no encountered any for a while. If you can GDB it for me and provide a stack trace that would be extremely useful.

Are you by chance also passing a value to game_end? ENIGMA's game_end works slightly differently than GM's and allows you to specify the return value, you could in fact try game_end(32); or some unique number to check it.
Logged
I think it was Leonardo da Vinci who once said something along the lines of "If you build the robots, they will make games." or something to that effect.

Offline (Unknown gender) qwerty
Reply #2 Posted on: January 19, 2015, 05:17:21 AM
Member
Joined: Jan 2015
Posts: 14

View Profile
when i run game first on debug mode and second on run mode, bug losts(for one compilation)
also dbg mode works normaly
so "if u can pass trough the bug its not a bug (c)" :eng101:

but i can run gdb from mingw if you think that its not only a my pc problm

added value, changed only ret num
« Last Edit: January 19, 2015, 05:44:43 AM by qwerty » Logged
Offline (Unknown gender) qwerty
Reply #3 Posted on: January 19, 2015, 06:13:34 AM
Member
Joined: Jan 2015
Posts: 14

View Profile
gbd tell me No stack
Logged
Offline (Male) Goombert
Reply #4 Posted on: January 19, 2015, 03:30:14 PM

Developer
Location: Cappuccino, CA
Joined: Jan 2013
Posts: 3107

View Profile
Actually the gdb tells us exactly why it is failing. OpenAL is failing to close a device which is why it's becoming an inferior process. You are on Windows XP, correct? Have you used other OpenAL applications before?
Logged
I think it was Leonardo da Vinci who once said something along the lines of "If you build the robots, they will make games." or something to that effect.

Offline (Unknown gender) qwerty
Reply #5 Posted on: January 19, 2015, 03:36:57 PM
Member
Joined: Jan 2015
Posts: 14

View Profile
Y, Y, alot(i mean may be alot), games like unreal2,  blender, etc...
but im dont worry about this bug
« Last Edit: January 19, 2015, 03:41:07 PM by qwerty » Logged
Offline (Male) Goombert
Reply #6 Posted on: January 19, 2015, 05:36:44 PM

Developer
Location: Cappuccino, CA
Joined: Jan 2013
Posts: 3107

View Profile
What operating system and version are you running this on? It seems like you need to debug your drivers, I really don't see how OpenAL could be failing to close.
Logged
I think it was Leonardo da Vinci who once said something along the lines of "If you build the robots, they will make games." or something to that effect.

Pages: 1
  Print