Pages: 1
  Print  
Author Topic: yet another xp java run/compile error  (Read 1020 times)
Offline (Unknown gender) qwerty
Posted on: January 14, 2015, 12:11:25 PM
Member
Joined: Jan 2015
Posts: 14

View Profile
(i have xp sp3(mb dmgt) amd sempron2200(dont have sse2! 8( ) gforcefx5500)

first problem i saw been standart unworked  %ProgramData% in settings.ey, i was changed it to normal path
but then i try to Run anything i take another error

...Running make from `mingw32-make.exe'
Full command line: mingw32-make.exe Game WORKDIR="%PROGRAMDATA%/ENIGMA/" GMODE=Run GRAPHICS=OpenGL1 AUDIO=OpenAL COLLISION=Precise WIDGETS=Win32 NETWORKING=None PLATFORM=Win32 CXXFLAGS="-std=c++11 -I../Additional/i686-w64-mingw32/include" COMPILEPATH="Windows/Windows" EXTENSIONS=" Universal_System/Extensions/Alarms Universal_System/Extensions/Timelines Universal_System/Extensions/BasicGUI Universal_System/Extensions/Paths Universal_System/Extensions/MotionPlanning Universal_System/Extensions/DateTime Universal_System/Extensions/ParticleSystems Universal_System/Extensions/DataStructures" OUTPUTNAME="C:/DOCUME~1/a/LOCALS~1/Temp/egm5383073784642032192.exe" eTCpath=""

java.lang.Error: Invalid memory access
   at com.sun.jna.Native.invokeInt(Native Method)
   at com.sun.jna.Function.invoke(Function.java:383)
   at com.sun.jna.Function.invoke(Function.java:315)
   at com.sun.jna.Library$Handler.invoke(Library.java:212)
   at com.sun.proxy.$Proxy0.compileEGMf(Unknown Source)
   at org.enigma.EnigmaRunner$CompilerThread.run(EnigmaRunner.java:671)

can it be coz WORKDIR="%PROGRAMDATA%/ENIGMA/" ?
Logged
Offline (Male) Goombert
Reply #1 Posted on: January 15, 2015, 08:25:45 AM

Developer
Location: Cappuccino, CA
Joined: Jan 2013
Posts: 3108

View Profile
Hello qwerty, the settings.ey has actually been changed and we hard code the values now until we can create a better interface for the global compiler settings. Follow the directions in the following topic with the updated XP fix:
http://enigma-dev.org/forums/index.php?topic=2379.15

Quote from: RobertBColton
Just change it manually in the file
CompilerSource\settings-parse\parse_ide_settings.cpp:146:  make_directory = "%PROGRAMDATA%/ENIGMA/";

You won't need the CLI, so just change that one line then launch ENIGMA again and then everything should finally work.

Let me know if this fixes it!
Logged
I think it was Leonardo da Vinci who once said something along the lines of "If you build the robots, they will make games." or something to that effect.

Offline (Unknown gender) qwerty
Reply #2 Posted on: January 15, 2015, 04:19:20 PM
Member
Joined: Jan 2015
Posts: 14

View Profile
after i just change .cpp its dont work(at start of prog i just take window with small recompiling, and same error then try to run)
but then i type rebuildcompiler in magic comandline bash its going to start second compile steps.

if i have some another compile bug after a while time i print it here
thanks you KoalaRobert
Logged
Offline (Unknown gender) qwerty
Reply #3 Posted on: January 15, 2015, 04:29:08 PM
Member
Joined: Jan 2015
Posts: 14

View Profile
compiling sucsessfull.
also i was read post with solution but miss it    :raise:
Logged
Offline (Male) Goombert
Reply #4 Posted on: January 15, 2015, 07:29:21 PM

Developer
Location: Cappuccino, CA
Joined: Jan 2013
Posts: 3108

View Profile
Ok wonderful! If you have any more issues don't be afraid to ask for help!
Logged
I think it was Leonardo da Vinci who once said something along the lines of "If you build the robots, they will make games." or something to that effect.

Pages: 1
  Print