Pages: « 1 2 3 4 5 »
  Print  
Author Topic: Linux & LGM  (Read 6042 times)
Offline (Unknown gender) Darkstar2
Reply #30 Posted on: June 19, 2014, 01:12:20 AM
Member
Joined: Jan 2014
Posts: 1244

View Profile Email
Ok Robert here is another bug for you to fix ;-)

Found what was causing code to be blanked.

Indeed just as I suspected, when I removed D&D from preference. This causes code NOT to get saved.  Only code in scripts get saved.

I think I know why too....... 

Perhaps it has to do with the fact when D&D is enabled and you double click on event, a "code icon" appears in the actions area just left of the D&D panel.  When D&D is disabled, this area also is gone along with the D&D panel.  Perhaps it is some variable or container or whatever that contains the code that gets disabled too with D&D being disabled and so when you save, it thinks there is nothing when in fact there is.

But I reproduced it ! With D&D enabled code inside events saves fine, without D&D code inside events gets blanked out when saved and reloaded, except scripts, so this is a good clue.

I hope this gets fixed because I really find it much better working without D&D panel and the action area, it frees a lot of screen space.


Logged
Offline (Male) Goombert
Reply #31 Posted on: June 19, 2014, 01:16:02 AM

Developer
Location: Cappuccino, CA
Joined: Jan 2013
Posts: 3107

View Profile
Wow, apparantly it is the option that's causing that, let me see if it does it with GMK or GMX.

Edit: I just tested and apparently that feature is broken for saving under EGM, I will investigate tomorrow. I also filed a bug report.
https://github.com/enigma-dev/lgmplugin/issues/21
« Last Edit: June 19, 2014, 01:18:12 AM by Robert B Colton » Logged
I think it was Leonardo da Vinci who once said something along the lines of "If you build the robots, they will make games." or something to that effect.

Offline (Unknown gender) Darkstar2
Reply #32 Posted on: June 19, 2014, 01:19:11 AM
Member
Joined: Jan 2014
Posts: 1244

View Profile Email
Wow, apparantly it is the option that's causing that, let me see if it does it with GMK or GMX.

Edit: I just tested and apparently that feature is broken for saving under EGM, I will investigate tomorrow.

lol ok so I seem to be a bug magnet !   

It's funny it is an option to disable D&D, but it's also disabling code too :D :P  ;D ??? ??? ??? ??? ???
Logged
Offline (Male) Goombert
Reply #33 Posted on: June 19, 2014, 11:58:11 AM

Developer
Location: Cappuccino, CA
Joined: Jan 2013
Posts: 3107

View Profile
Because the code is still an action, I just don't load the libraries but create the code action instead, so it should still be saving it. In fact I made this feature safe in that you can load a project with drag and drop without the action library being loaded, save it, reload it with DND enabled, and it will have kept the drag and drop just the way it was.
Logged
I think it was Leonardo da Vinci who once said something along the lines of "If you build the robots, they will make games." or something to that effect.

Offline (Unknown gender) Darkstar2
Reply #34 Posted on: June 19, 2014, 12:17:27 PM
Member
Joined: Jan 2014
Posts: 1244

View Profile Email
Because the code is still an action, I just don't load the libraries but create the code action instead, so it should still be saving it. In fact I made this feature safe in that you can load a project with drag and drop without the action library being loaded, save it, reload it with DND enabled, and it will have kept the drag and drop just the way it was.

Well it's very tricky, it's actually a blessing that LGM was crashing often !  Imagine if it were not and one is working on a large project for hours, saving as you go, thinking everything is saving fine.  As the code remains all there in plain view.  BUT it is not getting saved in the file. You only find out later when you re-load for whatever reason and see that all code is gone from everywhere.  lol.

It's as if when saving it is discarding all code contained in the events because of D&D being disabled. 
Logged
Offline (Male) Goombert
Reply #35 Posted on: June 19, 2014, 04:23:45 PM

Developer
Location: Cappuccino, CA
Joined: Jan 2013
Posts: 3107

View Profile
Well the sad news is, there's no easy way to fix this, EGM does not save kind and all that information in the format making reflection when the library is not available damn near impossible. See my updated comments on GitHub.
https://github.com/enigma-dev/lgmplugin/issues/21

For the time being there is no easy way to fix this, so if you want the EGM format you'll have to leave drag and drop enabled for now.
Logged
I think it was Leonardo da Vinci who once said something along the lines of "If you build the robots, they will make games." or something to that effect.

Offline (Unknown gender) Darkstar2
Reply #36 Posted on: June 19, 2014, 05:31:23 PM
Member
Joined: Jan 2014
Posts: 1244

View Profile Email
Reflection ? kind ? all ? I lost you there.  I can't believe I was happy to finally have gotten rid of D&D and Action area, and that doing so disables code lol.  I mean I can code it's there but it does not get saved, it's weird, all because of the gay action icons ??
Is there a way to make D&D and action STAY there but be invisible ?

This is not the news I wanted to hear :P
Guess we'll have to document this and warn people to not disable D&D and save to EGM. 

Logged
Offline (Male) Goombert
Reply #37 Posted on: June 19, 2014, 05:34:22 PM

Developer
Location: Cappuccino, CA
Joined: Jan 2013
Posts: 3107

View Profile
Why would I document that?

And no, I'll just turn back on loading of the action libraries.

Here's why:
GMK and GMX store the action kind, how it is executed, all of that information in your project, it's a tad unnecessary but it means you don't actually have to load the action libraries.
EGM does not save this information, just the action id and library id, so it requires the action library to be loaded.
When I originally did this I thought I could get away with not loading the action libraries making faster load times, but it appears we can't do that because of EGM.

So basically you can still use it, but LGM won't load any faster after I update it, but you'll be able to toggle dnd mode on and off without restarting again.
Logged
I think it was Leonardo da Vinci who once said something along the lines of "If you build the robots, they will make games." or something to that effect.

Offline (Unknown gender) Darkstar2
Reply #38 Posted on: June 19, 2014, 06:26:11 PM
Member
Joined: Jan 2014
Posts: 1244

View Profile Email
??? LGM loads near instantly on my system.  I have fast SATA3 drives and a fast system, and soon moving to SSD anyway.

It's not the extra few milliseconds that will really bother most people :D

Logged
Offline (Male) Goombert
Reply #39 Posted on: June 19, 2014, 06:55:41 PM

Developer
Location: Cappuccino, CA
Joined: Jan 2013
Posts: 3107

View Profile
I have fixed it by making the drag and drop action libraries load always.
https://github.com/IsmAvatar/LateralGM/commit/f5989c5f89a032ae62d67b1d420f2db27d689846

You can get these changes via install.py or by manually downloading and replacing the LateralGM and plugin jars from the Extra Packages page.
http://enigma-dev.org/docs/Wiki/Install:Extra_Packages

I will update the Portable ZIP once I finish fixing string dimension functions.
Logged
I think it was Leonardo da Vinci who once said something along the lines of "If you build the robots, they will make games." or something to that effect.

Offline (Male) time-killer-games
Reply #40 Posted on: June 19, 2014, 08:42:59 PM

Contributor
Location: Virginia Beach
Joined: Jan 2013
Posts: 1157

View Profile Email
Uhh.. What did you guys do to my topic? :P
Logged
Offline (Male) Goombert
Reply #41 Posted on: June 19, 2014, 08:55:02 PM

Developer
Location: Cappuccino, CA
Joined: Jan 2013
Posts: 3107

View Profile
Point is TKG you need a really good penis, and a 64bit ENIGMA.
Logged
I think it was Leonardo da Vinci who once said something along the lines of "If you build the robots, they will make games." or something to that effect.

Offline (Male) time-killer-games
Reply #42 Posted on: June 19, 2014, 09:04:03 PM

Contributor
Location: Virginia Beach
Joined: Jan 2013
Posts: 1157

View Profile Email
My penis is bigger than an elephant trunk. I'm not sure why I would need a 64 bit nigger when I'm not using a 64 bit Windows or a 64 bit Ubuntu VB.
Logged
Offline (Male) Goombert
Reply #43 Posted on: June 19, 2014, 09:11:27 PM

Developer
Location: Cappuccino, CA
Joined: Jan 2013
Posts: 3107

View Profile
Because the JVM limits a single thread to 1gb RAM on Windows and apparently 2.6gb's on Linux.

With 64bit Java I don't think there's a cap.
Logged
I think it was Leonardo da Vinci who once said something along the lines of "If you build the robots, they will make games." or something to that effect.

Offline (Male) edsquare
Reply #44 Posted on: June 19, 2014, 09:16:15 PM

Member
Location: The throne of ringworld
Joined: Apr 2014
Posts: 402

View Profile
Because the JVM limits a single thread to 1gb RAM on Windows and apparently 2.6gb's on Linux.

With 64bit Java I don't think there's a cap.

Fuck!

So I would need to change to 64Bit OSE's?

Fuck! Fuck! Fuck!

Will have to see if the rest of the applications I use run well under linuxmint 64Bits.

Also will have to accelerate the development of the IDE for ENIGMA.

Any sugestions about the name?
Logged
A child of five would understand this. Send someone to fetch a child of five.
Groucho Marx
Pages: « 1 2 3 4 5 »
  Print