Pages: 1
  Print  
Author Topic: View ports screwed up in ENIGMA  (Read 982 times)
Offline (Unknown gender) daz
Posted on: February 20, 2014, 02:26:58 AM
Contributor
Joined: Jul 2010
Posts: 167

View Profile
My setup:
64x64 sprite, assigned to obj. Obj has spacebar event with code:
Code: [Select]
view_wport[0] = 1280;
view_hport[0] = 720;
window_set_size(1280, 720);

Obj is in roughly center room. Room has default everything, except checked enable views and visible when game starts.

Expected: when spacebar is pressed, scaling viewport should cause screen to fill. What happens: who the hell knows.

Enigma: http://i.imgur.com/h8uEwAy.png
GM: http://i.imgur.com/e0agEzq.png

(GM has correct behavior)
Logged
Offline (Male) time-killer-games
Reply #1 Posted on: February 20, 2014, 09:01:31 AM

Contributor
Location: Virginia Beach
Joined: Jan 2013
Posts: 1157

View Profile Email
Two words.

Global. Game. Settings.

and check the radio tick box labeled "full scale"
Logged
Offline (Unknown gender) daz
Reply #2 Posted on: February 20, 2014, 10:25:02 AM
Contributor
Joined: Jul 2010
Posts: 167

View Profile
OK that is mostly a solution. I also had to manually offset the view_xview.

In GM "Keep aspect ratio" was still checked (not full scale), under the Windows tab, and it offset the view automatically.
Logged
Offline (Male) Goombert
Reply #3 Posted on: February 21, 2014, 04:14:10 PM

Developer
Location: Cappuccino, CA
Joined: Jan 2013
Posts: 3107

View Profile
Quote from: TKG
Two words.

Global. Game. Settings.
lmfao

Yeah that should be fixed though, I mean the offset stuff.
Logged
I think it was Leonardo da Vinci who once said something along the lines of "If you build the robots, they will make games." or something to that effect.

Pages: 1
  Print