Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Goombert

2836
General ENIGMA / Re: Perfect Circles
« on: May 28, 2013, 02:26:58 AM »
??? ExDeus they do, we just got that cubes demo working on Windows, so OpenGL3 and GLSL work on Windows now, it was just a makefile problem. The only thing I have not finished is materials and unform shader variables functions.

2837
General ENIGMA / Re: Perfect Circles
« on: May 27, 2013, 08:09:25 PM »
 :D

2838
General ENIGMA / Re: SwapBuffers Issue
« on: May 27, 2013, 08:08:57 PM »
Yes just as Josh said though guys, you should be creating the bridges folder for windowing, because we also need it to hook up a DX device to it.

2839
Announcements / Re: 1,000,000 Cubes
« on: May 27, 2013, 08:05:57 PM »
Damn Harri, nice graphics card  :D And yes when you guys are working on the frame swapping or whatever I think we should take the oppurtunity to implement MSAA and SSAA.

2840
General ENIGMA / Re: SwapBuffers Issue
« on: May 27, 2013, 11:46:38 AM »
Windowing systems need bridged also so the hWnd gets exposed so that it can be attached to a d3ddevice as well.

2841
Issues Help Desk / Re: Odd Sprite drawing issue
« on: May 27, 2013, 07:10:17 AM »
Hai gra  :D

2842
General ENIGMA / Re: SwapBuffers Issue
« on: May 27, 2013, 06:55:49 AM »
Well then that will go into OpenGL3, and whatever you do support goes into OpenGL1, so Deus I guess just focus on the OpenGL3 implementation, polygonz is the only one who OGL1 is needed for anyway besides Tsumi, and a few others.

I'm gone buy you a new computer polygonz :P

2843
General ENIGMA / Re: SwapBuffers Issue
« on: May 27, 2013, 06:48:50 AM »
Yep, if we are adding a frame buffer object, we need to set it up for anti-aliasing while we are at it so that it does not need written 2x.

2844
Announcements / Re: 1,000,000 Cubes
« on: May 27, 2013, 06:47:35 AM »
I was the one who implemented the rendering modes Deus, I have not touched them either since I originally added them.

2845
General ENIGMA / Re: SwapBuffers Issue
« on: May 27, 2013, 04:25:47 AM »
Oh ok yes that would make sense, hey are you on IRC? I got Ism's network functions working and made a simple client to server example and http request ^_^

Edit:

I made it do a simple http request and query our websites code ^_^

2846
General ENIGMA / Re: SwapBuffers Issue
« on: May 27, 2013, 04:12:39 AM »
Polygonz, hey bud, no lol I do not think I don't, no I'm %99.9999 percent certain you do not need a VBO. Vertex Buffer Objects just take the vertices in a model and pack them together into an object that handles storage and sends them to the GPU for fast rendering, so I do not know what that would have to do with tripple buffering?

Also while we are on fixing the double buffering and swapping, we should also take the oppurtunity to finally add MSAA and SSAA to the loop so it can down sample and then we can have some nice Anti-aliasing.

2847
General ENIGMA / Re: SwapBuffers Issue
« on: May 27, 2013, 03:49:54 AM »
Yah ExDeus is right, the whole point of double buffering is to get rid of flickering, you continue to draw what was last drawn while drawing the new stuff then swap at the end of draw events.

2848
General ENIGMA / Perfect Circles
« on: May 27, 2013, 02:35:42 AM »
I had a great idea of how we can make perfect circles in OpenGL3, make a flat plane, color it with a fragment shader  :D

2849
General ENIGMA / Re: Networking Systems *forthevin*
« on: May 26, 2013, 03:49:25 AM »
Hey ya good thing you caught that, thats one thing I missed. But its getting it from...
(extensions::targetAPI.networkSys)
Which the only reference I can find to is in that file :(

Edit: Ok I think I know it is that now, becuase I rename the none system to test and it still shows up as none, so perhaps its just setting that because it can't find it?

2850
General ENIGMA / Networking Systems *forthevin*
« on: May 26, 2013, 03:25:11 AM »
I recently got the chance to update the plugin and make networking systems show up as well as modified the makefile from SHELL and updated the compiler source to merge in the ENIGMANet multiplayer/networking functions from IsmAvatar. However I am having a problem, no matter what, it continues copying it as /None/ in APISwitchboard.h regardless of whether you set it in ENIGMASettings or I change its eyaml file to make it the default. You seem to know more about getting things to work properly in the engine like makefiles and stuff, do you think you could take a look at it? Everything is in my latest commit request.