Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Goombert

2716
Teamwork / Re: Remakes or original content
« on: July 17, 2013, 07:59:34 AM »
The only game I have ever thought about completely redoing open source was Sonic & Knuckles, I also still have not ported my Project Mario game into ENIGMA, I need object inheritance for particles.

2717
Issues Help Desk / Re: missing surface functions?
« on: July 17, 2013, 07:58:41 AM »
sidegame, can you please also run the glew test for me from the hard diagnosis thread...

http://enigma-dev.org/forums/index.php?topic=1131.0

2718
Works in Progress / Re: Project Mario
« on: July 16, 2013, 12:57:41 PM »
Awww, thank you slojanko  ;D

2719
Issues Help Desk / Re: missing surface functions?
« on: July 16, 2013, 12:55:29 PM »
Ohhh right, durrr me, ya just give us your driver information, and a DirectX diagnosis would be nice too, sidegame.  (Y)

ExDeus, he has to have a really fuck old PC though, or a very very very rare GFX card.

Edit: or no I guess not because he does have Vista or later it appears.

2720
Issues Help Desk / Re: missing surface functions?
« on: July 16, 2013, 11:33:33 AM »
Yup, has to be drivers or something, but then why does Game Maker work for him?

2721
Issues Help Desk / Re: missing surface functions?
« on: July 16, 2013, 11:03:49 AM »
Look at his picture Harri, it is at least Windows Vista or later. sidegame, you also did not by chance set DirectX did you? It don't even work.

2722
Teamwork / Re: Remakes or original content
« on: July 16, 2013, 10:19:45 AM »
I don't get what you are saying Harri. Josh is almost done with the compiler, the main thing stopping games from working is lack of polymorphism and inheritance and scripting errors.

2723
Issues Help Desk / Re: missing surface functions?
« on: July 16, 2013, 10:14:00 AM »
sidegame, how old is your pc?

2724
Issues Help Desk / Re: missing surface functions?
« on: July 15, 2013, 08:54:32 AM »
Yes I do, I am investigating your game now,  as you can see I was already aware of them not being "colored" in the code editor, do you understand? surface_reset_target() is colored, I am going to fix that bug. But let me investigate your game.  (Y)

Edit:

Your game works fine for me... o_O


Make sure you are using OpenGL 1 not 3

2725
Issues Help Desk / Re: missing surface functions?
« on: July 15, 2013, 01:56:37 AM »
Use the function anyway, it just does not have color, trust me it works, it is just not colored, keep it on OpenGL1, OpenGL3 is not necessary. If you get errors please go to http://pastebin.com and upload them for me and post the link.

2726
Issues Help Desk / Re: audio_play_music() making game crash!
« on: July 14, 2013, 11:41:48 AM »
lolman, it is not, I have instead been recoding LateralGM in C++, and I can not give you an estimated release date yet.


2727
Issues Help Desk / Re: audio_play_music() making game crash!
« on: July 14, 2013, 11:08:41 AM »
Harri, blame that on IsmAvatar  :ohdear:

Also, I am sorry the audio functions are not documented on the Wiki yet, I just did all string functions this morning and am currently working on path functions of which I have half done.

2728
Issues Help Desk / Re: audio_play_music() making game crash!
« on: July 14, 2013, 10:49:50 AM »
lolman, use sound_play for now, I have to fix that audio_play_music function  (Y)

2729
Issues Help Desk / Re: audio_play_music() making game crash!
« on: July 14, 2013, 10:35:12 AM »
Hello lolman, I am sorry I did not see your post. Yes I have discovered myself there is a bug with that function, audio_play_sound however works fine. For now while I am still working on audio currently, please just use the sound_play and sound_* functions  (Y)

2730
Issues Help Desk / Re: missing surface functions?
« on: July 14, 2013, 06:09:48 AM »
sidegame, they do exist, they just are not syntax higlighting in the script editor, I am not sure what is causing this bug, I believe it might be something to do with the mergal of our script editing component, JoshEdit, because JEdit was supposed to use a hard coded keyword list, and I believe this is being passed to JoshEdit now. This needs to be investigated and resolved. Go ahead and use the functions, they just won't be colored like all the other functions inside that window until someone fixes it.  (Y)