Pages: 1
  Print  
Author Topic: Compiling in Linux (Solved)  (Read 973 times)
Offline (Unknown gender) joserc87
Posted on: April 21, 2011, 04:10:05 PM
Member
Joined: Apr 2011
Posts: 2

View Profile
Hi.
First of all, congratulations for the proyect. I thougt to do something similar for years.
Ok, I couldnt download the .deb file from dropbox, so i have done a svn -co from the repository and tried to compile in linux. Everithing seems to work fine. I open the .jar and try to run a game, and then I get a linker error from the g++. I notice that this seem the last step to compile so i try to find the error and I read:
g++ SHELLmain.cpp libEGMstd.cpp Graphics_Systems/OpenGL/.eobjs_Run/*.o Platforms/xlib/.eobjs_Run/*.o Universal_System/.eobjs_Run/*.o Audio_Systems/OpenAL/.eobjs_Run/*.o Collision_Systems/BBox/.eobjs_Run/*.o Audio_Systems/OpenAL/.eobjs_Run/*.a Audio_Systems/OpenAL/.eobjs_Run/libogg.a Widget_Systems/None/.eobjs_Run/*.o -lz -lGL -lGLU -lopenal -o /home/joserc87/tar/enigma-dev-svn/enigma-dev/trunk

but trunk is a dir, so g++ cant create the output file. I've changed with ...trunk/something (in a terminal) and it compiles, but doesnt work like expected. There arent any resources in the program, so all I see is a black window and a keyboard tester in the terminal.
How can I solve? I'm very curious about this project and wanna try it.

Thanks.
(Note: As you can notice, I'm not an English speeker :eng99: (really I'm spanish) so sorry for my bad English. I hope you can understand what I've said  :)).
« Last Edit: April 22, 2011, 05:25:30 PM by IsmAvatar » Logged
Offline (Female) IsmAvatar
Reply #1 Posted on: April 21, 2011, 04:20:28 PM

LateralGM Developer
LGM Developer
Location: Pennsylvania/USA
Joined: Apr 2008
Posts: 877

View Profile Email
1) Care to share what was wrong with the .deb?
2) You need to also share the revision you're using to get help.
3) svn co https://enigma-dev.svn.sourceforge.net/svnroot/enigma-dev/trunk enigma-dev
That will checkout the trunk of the project (bleeding edge, yadda yadda). It looks like you might have checked out from the svnroot, and got a lot more than you bargained for. Alternatively, if you don't care about bleeding edge and just want a version that works, consider checking out the stable branch:
svn co https://enigma-dev.svn.sourceforge.net/svnroot/enigma-dev/tags/update-stable enigma-dev
4) I'm not entirely sure, but you might be experiencing this problem because of problems with the latest revision. Again, consider checking out the stable branch instead, because we do break the trunk from time to time. Alternatively, consider reverting to a slightly older revision, `svn up -r 700` before we broke it, or wait until we fix it.
5) Consider joining the IRC to get faster help and to talk to the devs directly. We know what we're doing on the IRC, but kinda fumble around on the forums.
« Last Edit: April 21, 2011, 04:32:28 PM by IsmAvatar » Logged
Offline (Male) Josh @ Dreamland
Reply #2 Posted on: April 21, 2011, 04:40:39 PM

Prince of all Goldfish
Developer
Location: Pittsburgh, PA, USA
Joined: Feb 2008
Posts: 2949

View Profile Email
Sorry about that, Joserc. We've been making some reparations to get ENIGMA working on Mac, iPhone, and Android out of the box. As IsmAvatar said, you can revert to an older revision that still works using the SVN up command. I recommend revision 710.

To check out new, use this:
svn co https://enigma-dev.svn.sourceforge.net/svnroot/enigma-dev/trunk enigma-dev -r 710

To revert, use this:
svn up -r 710
« Last Edit: April 21, 2011, 04:56:06 PM by Josh @ Dreamland » Logged
"That is the single most cryptic piece of code I have ever seen." -Master PobbleWobble
"I disapprove of what you say, but I will defend to the death your right to say it." -Evelyn Beatrice Hall, Friends of Voltaire
Offline (Unknown gender) joserc87
Reply #3 Posted on: April 21, 2011, 07:46:54 PM
Member
Joined: Apr 2011
Posts: 2

View Profile
Yes, this revision 710 works fine. Now I feel a bit stupid checking out the latest version and asking why doesnt work hehehe :P.
This look good. Congratulations again! I thing this is a proyect the world needed.

Best wishes.
Logged
Pages: 1
  Print