ENIGMA Development Environment
Website is in read-only mode due to a recent attack.

Pages: 1 2 »
  Print  
Author Topic: Install Enigma on Mac  (Read 5177 times)
Offline (Male) fredcobain
Posted on: July 04, 2011, 11:12:54 PM

Member
Location: Brazil
Joined: Apr 2011
Posts: 40
MSN Messenger - fredcobain@gmail.com
View Profile
Hi masters,

I've downloaded the SVN repo in a folder in a Mac OS X Snow Leopard instance.

Now I have tons of folders....

which is the LGM.jar that I have to calll to work with Enigma in Mac ?

My instincts guide me to go to "update-stable" folder....
and when I try to open the jar file, the LGM complains that could not find the MAKER.

What can I do ?


Thanks in advance.

Fred
« Last Edit: July 04, 2011, 11:15:30 PM by fredcobain » Logged
Offline (Male) Josh @ Dreamland
Reply #1 Posted on: July 05, 2011, 12:28:05 AM

Prince of all Goldfish
Developer
Location: Pittsburgh, PA, USA
Joined: Feb 2008
Posts: 2951

View Profile Email
That depends mostly on TGMG. Most of the developers and those active in the IRC go with trunk/. That folder, though we try to keep it working as best as we can, often ends up accidentally destroyed. We maintain stable mostly to work on Windows. It pretty much always works on Linux; Mac, however, is still foreign to most of us, and usually isn't considered in marking as stable.

That said, I don't know which to recommend on Apple. I'd probably try trunk/ first since we don't ensure consistency on tags/update-stable on Mac. If that fails, though, maybe TGMG maintains the stable tag of Mac...

If both fail, wait for TGMG to respond. He keeps what's basically a fork of the project for Mac on his own Git repository. It is the most likely to work, but it has some test-related quirks...
Logged
"That is the single most cryptic piece of code I have ever seen." -Master PobbleWobble
"I disapprove of what you say, but I will defend to the death your right to say it." -Evelyn Beatrice Hall, Friends of Voltaire
Offline (Unknown gender) TGMG
Reply #2 Posted on: July 05, 2011, 08:00:19 PM

Developer
Joined: Jun 2008
Posts: 107

View Profile WWW Email
It works on both update-stable and trunk, I would personally suggest trunk as thats what I use and its working.

Can you paste the errors here?
You say it can't find MAKER? if its missing MAKE then you need to install the mac sdk which you can get from the apple website.
Logged
me
GMbed 2.0 :: Embed you gm games in websites.
Offline (Male) fredcobain
Reply #3 Posted on: July 05, 2011, 09:00:37 PM

Member
Location: Brazil
Joined: Apr 2011
Posts: 40
MSN Messenger - fredcobain@gmail.com
View Profile
TGMG, do you mean the Android SDK or Iphone SDK ?

I did not find MAC SDK. Can you point me the link ?


Thank you so much.


Btw, these are the error I found when I call the jar file of LGM (now in trunk directory):


Enigma cannot run because it requires the "MAKE" tool, which could not be found.
Please make sure 'MAKE' is properly installed and then restart the application


Quote
Unhandled Exception:
org.lateralgm.file.GmFormatException - java.io.IOException: Cannot run program "make" (in directory "/Users/User/SVN/enigma-dev/trunk"): error=2, No such file or directory

Stack trace:
java.lang.ProcessBuilder.start(ProcessBuilder.java:460)
java.lang.Runtime.exec(Runtime.java:593)
java.lang.Runtime.exec(Runtime.java:431)
org.enigma.EnigmaRunner.make(EnigmaRunner.java:247)
org.enigma.EnigmaRunner$2.run(EnigmaRunner.java:146)


Update:

Oh, now I underestand.... the Iphone SDK contains the Mac SDK.

And you should 1st register in Apple Developers WebSite.

You have to download the "XCODE3.2.6 and IOS SDK 4.3"

4.3GB.

After that it should solve my problem... lets see... will post here the results.





Fred
« Last Edit: July 05, 2011, 10:00:54 PM by fredcobain » Logged
Offline (Female) IsmAvatar
Reply #4 Posted on: July 06, 2011, 05:25:18 PM

LateralGM Developer
LGM Developer
Location: Pennsylvania/USA
Joined: Apr 2008
Posts: 877

View Profile Email
You can download a torrent of it instead. Save you from selling your soul to Mac anymore than you already have.
Logged
Offline (Male) fredcobain
Reply #5 Posted on: July 06, 2011, 05:47:57 PM

Member
Location: Brazil
Joined: Apr 2011
Posts: 40
MSN Messenger - fredcobain@gmail.com
View Profile
You can download a torrent of it instead. Save you from selling your soul to Mac anymore than you already have.

Too late, Ism.... they have my soul.  ;D

Well.... I've installed the IOS SDK and the MAC SDK now, I got a different error when I start LGM:

Quote
ENIGMA: Unable to comunicate with the library,
Either because could not be found or uses methods different from those expected.
The exact error is:
Unable to load library 'compileEGMF': dlopen(libcompileEGMf.dylib,9):image not found).


=(
Logged
Offline (Female) IsmAvatar
Reply #6 Posted on: July 06, 2011, 05:50:10 PM

LateralGM Developer
LGM Developer
Location: Pennsylvania/USA
Joined: Apr 2008
Posts: 877

View Profile Email
I don't know what to make of that. Sounds like it produced a corrupt dylib.

The error you're receiving is exactly what it says, and it's probably one of the most self-explanatory errors I've ever written. It either means that the library didn't compile correctly, or it's using different methods (pretty much impossible), or it's missing altogether. Obviously the first thing to check would be whether the file "libcompileEGMf.dylib" actually exists, or maybe "compileEGMf.dylib". If it exists, it should be in the main enigma directory. If not, then there's your problem. If it exists, try renaming it by adding or removing the "lib" at the beginning. If that fixes it, let me know. Aside from those suggestions, I got nothing. It's corrupt or missing. It is what it is.
« Last Edit: July 06, 2011, 05:54:48 PM by IsmAvatar » Logged
Offline (Male) fredcobain
Reply #7 Posted on: July 06, 2011, 05:52:06 PM

Member
Location: Brazil
Joined: Apr 2011
Posts: 40
MSN Messenger - fredcobain@gmail.com
View Profile
I don't know what to make of that. Sounds like it produced a corrupt dylib.

Stupid Mac!  >:(
Logged
Offline (Female) IsmAvatar
Reply #8 Posted on: July 06, 2011, 05:55:01 PM

LateralGM Developer
LGM Developer
Location: Pennsylvania/USA
Joined: Apr 2008
Posts: 877

View Profile Email
Sorry, see my edit.
Logged
Offline (Male) fredcobain
Reply #9 Posted on: July 06, 2011, 06:14:29 PM

Member
Location: Brazil
Joined: Apr 2011
Posts: 40
MSN Messenger - fredcobain@gmail.com
View Profile
Ism, there is no compileEGMf.dylib in my Mac.

Just a compileEGMf.cbp on Trunk/CompilerSource folder....

Does anyone can send me this file ?

=/
Logged
Offline (Female) IsmAvatar
Reply #10 Posted on: July 06, 2011, 06:21:16 PM

LateralGM Developer
LGM Developer
Location: Pennsylvania/USA
Joined: Apr 2008
Posts: 877

View Profile Email
Ah, ok, that's less of a concern then. LGM should have tried to call `make` to compile Enigma and produce a dylib. At some point during that it failed, and should have displayed an error saying such - before it complained about the communication issue.
Logged
Offline (Male) fredcobain
Reply #11 Posted on: July 06, 2011, 07:10:11 PM

Member
Location: Brazil
Joined: Apr 2011
Posts: 40
MSN Messenger - fredcobain@gmail.com
View Profile
mmm... what should i do ?


I feel that's why I cant open Enigma settings....

And I cant run....

Error Message:
Quote
(Enigma is not functional due to prior errors)
« Last Edit: July 06, 2011, 07:18:20 PM by fredcobain » Logged
Offline (Female) IsmAvatar
Reply #12 Posted on: July 06, 2011, 07:53:01 PM

LateralGM Developer
LGM Developer
Location: Pennsylvania/USA
Joined: Apr 2008
Posts: 877

View Profile Email
Like I said, there's a prior error before the "Unable to communicate" error. Please report that one. The "Unable to communicate" error tells us "Something went wrong earlier, so the library is unusable." We need to find out what went wrong earlier, and as far as I'm aware, there's a dozen failsafes in place that should have been reporting errors long before you got the "Unable to communicate" error. We need those errors, or else all we can tell you is that the dylib is missing for some reason. The other, prior, errors, will tell you exactly why it is missing.
Logged
Offline (Male) fredcobain
Reply #13 Posted on: July 06, 2011, 08:01:40 PM

Member
Location: Brazil
Joined: Apr 2011
Posts: 40
MSN Messenger - fredcobain@gmail.com
View Profile
Yes, the prior error should be:


Quote
ENIGMA: Unable to comunicate with the library,
Either because could not be found or uses methods different from those expected.
The exact error is:
Unable to load library 'compileEGMF': dlopen(libcompileEGMf.dylib,9):image not found).


It happens when LGM finishes it loading.


The other error ( (Enigma is not functional due to prior errors) ) occurs when I try to run.
Logged
Offline (Unknown gender) TGMG
Reply #14 Posted on: July 06, 2011, 10:13:29 PM

Developer
Joined: Jun 2008
Posts: 107

View Profile WWW Email
Open terminal, type:
cd "path to trunk folder"
java -jar lgm1*

wait for it to finish giving alot of text output in the terminal, and copy and paste it here.
Logged
me
GMbed 2.0 :: Embed you gm games in websites.
Pages: 1 2 »
  Print