Recent Posts

Pages: « 1 2 3 4 5 6 7 8 9 10 »
Issues Help Desk / Re: Can't get Enigma to work under windows 10
« Last post by ultima666 on October 21, 2020, 06:44:57 am »
hello i have the same isssie and i also have this
LateralGM Version: 1.8.198
Working Directory: C:\msys64\home\J-M\enigma-dev\lateralgm.jar

Operating System: Windows 10
Version: 10.0
Architecture: amd64

Java Name: Java HotSpot(TM) 64-Bit Server VM
Java Vendor: Oracle Corporation
Version: 1.8.0_261

Current Thread: Thread-8
Available processors (cores): 16
Free memory (bytes): 334149752
Maximum memory (bytes): 7615283200
Total memory available to JVM (bytes): 407896064

File system root: C:\
Total space (bytes): 1999798726656
Free space (bytes): 1710493429760
Usable space (bytes): 1710493429760

File system root: D:\
Total space (bytes): 4000768323584
Free space (bytes): 1966052728832
Usable space (bytes): 1966052728832

File system root: E:\
Total space (bytes): 750166994944
Free space (bytes): 169696907264
Usable space (bytes): 169696907264

File system root: F:\
Total space (bytes): 12000119746560
Free space (bytes): 527499485184
Usable space (bytes): 527499485184

File system root: G:\
Total space (bytes): 8001427599360
Free space (bytes): 560121462784
Usable space (bytes): 560121462784

File system root: H:\
Total space (bytes): 650829824
Free space (bytes): 0
Usable space (bytes): 0

Stack trace:
org.lateralgm.file.GmFormatException: Cannot run program "make" (in directory "C:\msys64\home\J-M\enigma-dev"): CreateProcess error=2, Le fichier spécifié est introuvable
   at java.lang.ProcessBuilder.start(Unknown Source)
   at java.lang.Runtime.exec(Unknown Source)
   at java.lang.Runtime.exec(Unknown Source)
   at org.enigma.EnigmaRunner.make(
   at org.enigma.EnigmaRunner$
Issues Help Desk / Can't get Enigma to work under windows 10
« Last post by lordsifl on October 20, 2020, 03:10:20 pm »
I have the last version of the program that ran under windows(windows 7)

I get a message on win10

Unable to load library'compileEGMf':native library (Win32-x86-64/compileEGMf.dll) not found in resource path (file/C:Enigma/enigma-dev/plugins/enigma.jar))

But the files are all there like under win7.  I found compileEGMf.dll and enigma.jar.  Can I fix this?
Issues Help Desk / Re: Adding Sound causes "Game returned -1073741819"
« Last post by Kahmore on October 18, 2020, 12:39:20 pm »
I was able to pacman -Sy gdb, seeing as it apparently does *not* come preinstalled as otherwise suggested. Here is the output when I follow the steps in the debugging wiki section around gdb:

Code: [Select]
Starting program: /c/msys64/tmp/egm913556157439571773.exe
[New Thread 1372.0xad4]
[New Thread 1372.0x98c]
[New Thread 1372.0xdd0]
[New Thread 1372.0x293c]
[New Thread 1372.0x14d4]
[New Thread 1372.0x1248]
[New Thread 1372.0x2a6c]
[Thread 1372.0x1248 exited with code 0]
[Thread 1372.0x2a6c exited with code 0]
[New Thread 1372.0x1640]
[Thread 1372.0x14d4 exited with code 0]
[New Thread 1372.0x2b38]
[New Thread 1372.0x1900]
[New Thread 1372.0x2650]
[New Thread 1372.0x216c]
warning: onecore\com\combase\objact\objact.cxx(827)\combase.dll!00007FFE7F760BC9: (caller: 00007FFE7F75F99A) ReturnHr(1) tid(1084) 800401F0 CoInitialize has not been called.
[New Thread 1372.0x404]
[New Thread 1372.0x9e8]

Thread 1 received signal SIGSEGV, Segmentation fault.
enigma::sound_add_from_buffer (id=0, buffer=0x4763fd0, bufsize=7352)
    at Audio_Systems/DirectSound/DSsystem.cpp:189
189                                 0))                    // Flag.
(gdb) bt
#0  enigma::sound_add_from_buffer (id=0, buffer=0x4763fd0, bufsize=7352) at Audio_Systems/DirectSound/DSsystem.cpp:189
#1  0x0000000000488b03 in enigma::exe_loadsounds (exe=0x7ffe7f6cfa90 <msvcrt!_iob+144>)
    at Universal_System/Resources/soundinit.cpp:66
#2  0x0000000000485ef4 in enigma::initialize_everything () at Universal_System/Resources/loading.cpp:107
#3  0x00000000004087ab in enigma::enigma_main (argc=1, argv=0x28a6080) at Platforms/General/PFmain.cpp:85
#4  0x000000000040ee67 in WinMain (hInstance=0x400000, hPrevInstance=0x0, lpCmdLine=0x28b4348 "", iCmdShow=10)
    at Platforms/Win32/WINDOWSmain.cpp:460
#5  0x00000000006860b2 in main (flags=<optimized out>, cmdline=<optimized out>, inst=<optimized out>)
    at C:/_/M/mingw-w64-crt-git/src/mingw-w64/mingw-w64-crt/crt/crt0_c.c:18
#6  0x00000000004013c1 in __tmainCRTStartup () at C:/_/M/mingw-w64-crt-git/src/mingw-w64/mingw-w64-crt/crt/crtexe.c:333
#7  0x00000000004014f6 in mainCRTStartup () at C:/_/M/mingw-w64-crt-git/src/mingw-w64/mingw-w64-crt/crt/crtexe.c:212
(gdb) _
Issues Help Desk / Re: Adding Sound causes "Game returned -1073741819"
« Last post by Kahmore on October 16, 2020, 08:41:24 pm »
For reference, I installed using the directions on
I've tried with both the dll provided in that topic you linked and the openal dll found in my mingw installation (obviously not at the same time!), copied them into msys64/tmp which is where enigma has been creating the exes. No luck either way:
Code: [Select]
[g++] Universal_System/Resources/spriteinit.cpp
echo // GENERATED RESOURCE FILE FRONTEND > C:/Users/K/AppData/Local/ENIGMA/.eobjs/Windows/Windows/Mingw_GCC_G++/Debug/resources.rc
for res in Preprocessor_Environment_Editable/Resources.rc Widget_Systems/Win32/resources.rc; do echo "#include \"$res\"" >> C:/Users/K/AppData/Local/ENIGMA/.eobjs/Windows/Windows/Mingw_GCC_G++/Debug/resources.rc; done
Linking C:/msys64/tmp/egm8290042648037077027.exe
C:/msys64/mingw64/bin/../lib/gcc/x86_64-w64-mingw32/10.2.0/../../../../x86_64-w64-mingw32/bin/ld.exe: cannot find -lmodplug
w64-mingw32/10.2.0/../../../../x86_64-w64-mingw32/bin/ld.exe: cannot find -lmodplug
w64-mingw32/10.2.0/../../../../x86_64-w64-mingw32/bin/ld.exe: cannot find -lmodplug
collect2.exe: error: ld returned 1 exit status
make[1]: *** [Makefile:172: compile_game] Error 1
make[1]: Leaving directory '/c/ENIGMA/enigma-dev/ENIGMAsystem/SHELL'
collect2.exe: error: ld returned 1 exit status
collect2.exe: error: ld returned 1 exit status
make[1]: *** [Makefile:172: compile_game] Error 1
make[1]: Leaving directory '/c/ENIGMA/enigma-dev/ENIGMAsystem/SHELL'
make[1]: *** [Makefile:172: compile_game] Error 1
make: *** [Makefile:25: Game] Error 2
make: Leaving directory '/c/ENIGMA/enigma-dev'
make[1]: Leaving directory '/c/ENIGMA/enigma-dev/ENIGMAsystem/SHELL'
make: *** [Makefile:25: Game] Error 2
make: Leaving directory '/c/ENIGMA/enigma-dev'
make: *** [Makefile:25: Game] Error 2
make: Leaving directory '/c/ENIGMA/enigma-dev'

As far as the gdb route goes, as per it suggests that enigma comes with its own MinGW (I don't see it in the enigma-dev directory - I had to install msys64 myself) and suggests using git-bash.bat (also not seeing it?) and I can't seem to find gdb in my MinGW (although I do see gcc)?

Forgive me if I need a little hand-holding, I'm still a bit of a rookie when it comes to programming XD
Issues Help Desk / Re: Adding Sound causes "Game returned -1073741819"
« Last post by time-killer-games on October 16, 2020, 07:47:17 pm »
You can get the dll you need here:

But it should already exist in your MinGW installation and the one I uploaded is probably outdated at this point.

I can't speak for DirectSound without more information. I never had issues with it using wav.

run in debug mode and use gdb like mentioned on the wiki. Wait until it crashes and give us a pastebin of the backtrace.
Issues Help Desk / Adding Sound causes "Game returned -1073741819"
« Last post by Kahmore on October 16, 2020, 04:15:44 pm »
Installed ENIGMA (and LateralGM) on my 64 bit Windows 10 yesterday after a haitus. After a few small miracles, I did actually get it to work (installation is not exactly intuitive, is it? XD).
Am quite enjoying using it, but I wasn't able to get sounds to work, so I was hoping for some help on that.

What I do:
Launch mingw64, cd to enigma-dev, and java -jar lateralgm.jar. Everything starts up great.
Create a Room resource. Notice some weird exceptions in the console, but otherwise it seems to be working
Run (empty game with 1 room - the test case). Game starts up fine. I then exit the game.
Create a Sound resource (but don't populate it).
Run. Game starts up fine. I exit the game.
Load a simple wav file (just something I found on the internet of someone saying "one") into said sound resource.
Run. Compilation seems to go fine. Game attempts to start but instantly closes in a flash. Console tells me:

Code: [Select]
Running "C:/msys64/tmp/egm5657834002195878703.exe"

Game returned -1073741819

I've left it to the default settings, so I believe it's trying to use DirectSound. Not sure if there's anything fancy I have to do to get that working?
I also tried switching it over to OpenAL, but it complained about missing libraries which I wasn't able to figure out how to install (I saw the announcement post saying to run "pacboy -S libmodplug:x" but "pacboy" does not exit... so I tried using pacman instead but it doesn't find any libraries like that). Doesn't matter to me which one I use, just as long as it works XD.

General ENIGMA / Re: OpenSuse Support for Enigma
« Last post by hpg678 on October 15, 2020, 12:37:49 pm »
Thanks for that Hitcoder. To be honest I have made it my main work machine. What can I say, its works so well. ;) (Y) ;)
General ENIGMA / Re: OpenSuse Support for Enigma
« Last post by HitCoder on October 05, 2020, 12:05:08 pm »
This is awesome, Hugar! Thanks for making this, hopefully it will make Enigma a more accessible platform for OpenSuse users.  :D :D :D
Works in Progress / Re: PolyOne, (Updated 07-Aug-2020 to
« Last post by Josh @ Dreamland on September 13, 2020, 06:28:06 pm »
If I recall correctly from the wiki, the ENIGMA license does permit using it to develop commercial software. Even so, am I incorrect in my remembering this and are there any gotchas I should watch out for that may invalidate that permission?
We're specifically looking to exclude this usecase from our GPL exemption—IDEs using ENIGMA logic would have to share its license (or default to pure GPL). Only games created by the end user will be exempt from GPL (and allowed to remain closed-source).

Should it be possible to run Ubuntu on VMWare Player 3.0?
I assume so, but I am unfamiliar with that particular VM.

Would it be enough to do a PolyOne build, make sure it all seems to be working, then make that a release candidate, or is there some reason that I would have to create individual builds for different Linux distros? My guess is the answer is no, as most Linux and Windows-compatible software I have seen does not have different versions for different Linux distros.
Generally, it's an issue of convenience. Most software teams only support Ubuntu, and other distributions pick up the slack from there.

Should I expect a poor reception as a result of not sharing the source code of PolyOne?
Not necessarily. Different people care differently about their software's license, so long as it meets their usecase.

I don't have plans to include any kind of copy protection in the paid version. Is it something I should be worried about?
Probably not. People will pay for your software if they feel like it. Any protection would serve as a barrier to new users and would be circumvented quickly by pirates if your software was worth it.

There are a few similarities that my software has, at least visually, to many other pieces of software. I don't consider it possible to avoid every piece of software which has ever been created, and PolyOne isn't the only case of this situation. Should I be worried about patent trolls trying to sue me for obscene amounts of money?
There is a lot of prior art in the game development space which tends to render that impossible. ENIGMA's viral licensing is part of its survival tactics, there, however.

Does the Patreon only fund RadialGM, or does it also include ENIGMA?
The Patreon supports both projects (the developer base is the same).
General ENIGMA / Re: OpenSuse Support for Enigma
« Last post by hpg678 on August 18, 2020, 06:24:11 am »
The instructions have been updated in the Wiki with additional links to install the libdumb library. libdumb is needed for producing sound via the OpenAL API.  SFMLis no longer supported through the same API widget as OpenAL so it was necessary to provide this update.
To get the library you will need to type some CLI commands in the Terminal as you need to add an additional repository to get the package.
Pages: « 1 2 3 4 5 6 7 8 9 10 »