Pages: 1
  Print  
Author Topic: SOLVED - Invalid Memory Address (invokePointer) on startup  (Read 960 times)
Offline (Unknown gender) Solitudinal
Posted on: August 26, 2017, 02:31:38 pm
Member
Joined: Aug 2017
Posts: 23

View Profile
Windows 10

Code: [Select]
java.lang.Error: Invalid memory access
        at com.sun.jna.Native.invokePointer(Native Method)
        at com.sun.jna.Function.invokePointer(Function.java:470)
        at com.sun.jna.Function.invoke(Function.java:415)
        at com.sun.jna.Function.invoke(Function.java:315)
        at com.sun.jna.Library$Handler.invoke(Library.java:212)
        at com.sun.proxy.$Proxy0.definitionsModified(Unknown Source)
        at org.enigma.backend.EnigmaSettings.commitToDriver(EnigmaSettings.java:247)
        at org.enigma.EnigmaRunner$3.run(EnigmaRunner.java:208)

So enigma was working fine yesterday, but today I added a new hard drive and moved my Desktop folder (which contained enigma) and some other folders (Documents, etc - but not Program Files or ProgramData) to the new E: drive. It started throwing this error, so I reinstalled enigma to C:\gamedev\ENIGMA and tweaked the usual things:

settings.ini
Code: [Select]
...
redirectoutput=0
closecmd=0
...
idecommand="C:\Program Files (x86)\Java\jre1.8.0_74\bin\java.exe -jar -Xms256m -Xmx1000m"
(I do java dev, so I needed to explicitly point it to my 32-bit java. I also told the console to stay around so I can see what's going on)

enigma-dev/settings.ey
Code: [Select]
...
    -make-directory:
...
        Default-Windows: "C:/ProgramData/ENIGMA/"
(That directory does exist). As per the usual solution to Invalid Memory Address problems. Doesn't seem to make a difference if I change this or not, though.

Unfortunately, after the long build process, it's still throwing the exact same error as above.
I also did a "git pull", in case something was outdated, but after it rebuilt the necessary pieces, it still threw the exact same error.

This is quite bizarre since it just worked yesterday.


What exactly happens is I open ENIGMA.exe, the console appears and LateralGM appears, and the console text scrolls for a little bit, and then stops with the aforementioned error - and LateralGM shows the error in a popup.
In other words, it's during startup.
I can close the error and continue to use LateralGM without ENIGMA, but I kinda need ENIGMA, lol.


Update: Forgot to Run as administrator. It used to automatically run as admin, but the move must have changed that. Ran as admin again and it all works again.
« Last Edit: August 26, 2017, 03:21:30 pm by Solitudinal » Logged
Offline (Male) hpg678
Reply #1 Posted on: August 28, 2017, 03:36:59 pm

Member
Location: Barbados
Joined: Mar 2017
Posts: 283

View Profile Email
Happy to hear of your success.

TIP:  Another way you can do things is to create a shortcut of said program..........ENIGMA for instance. Click on 'Properties' and among the series of tabs, you should have one named [Compatibility]. Go down to "Privileges' and select the [Run As Administrator] check box.

the above method works for Windows 7 but you can achieve the same result in Windows 10, though the wording or placement may be different.
Logged
[compromised account]
Pages: 1
  Print