Opensuse Linux Installation

From ENIGMA

Jump to: navigation, search
The official logo of Opensuse based operation systems and distributions.

The recommended way to install Enigma on Linux-based systems is through the source code. Opensuse users should follow these instructions below. * Please bear in mind this method is experimental and you may need to do additional steps to get the full usage....

Easy method for Opensuse Users
On Opensuse Linux and its distributions copy this code into a file and name it "install.sh" *Make sure that you give it permissions to run as an executable file.
#!/bin/bash
cd ~/
echo "Installing dependencies..."

sudo zypper install git gcc gdb pkgconf protobuf-devel protobuf-c zlib-devel glew glew-devel glm-devel glu-devel Mesa openal-soft-tools libogg-devel alure-devel libvorbis-devel vorbis-tools libBox2D-devel libSDL2-devel libfreetype6 libffi-devel libX11-devel libXrandr-devel libXinerama-devel rapidjson-devel yaml-cpp-devel boost-devel pulseaudio pugixml-devel libgme-devel

echo "Downloading Enigma..."
git clone git://github.com/enigma-dev/enigma-dev.git

cd enigma-dev

echo "Downloading easy startup script..."
wget https://pastebin.com/raw/aBAU4j3C -O start.sh
sed -i -e 's/\r$//' start.sh

echo "Correcting permissions..."
chmod +x start.sh
chmod +x install.sh

echo "Installing..."
./install.sh

echo "Done, to start Enigma just run ~/enigma-dev/start.sh"

Contents

Installing Dependencies

    sudo zypper install git gcc gdb pkgconf protobuf-devel protobuf-c zlib-devel glew glew-devel glm-devel 
                glu-devel Mesa openal-soft-tools libogg-devel alure-devel libvorbis-devel vorbis-tools 
                libBox2D-devel libSDL2-devel libfreetype6 libffi-devel libX11-devel libXrandr-devel 
                libXinerama-devel rapidjson-devel yaml-cpp-devel boost-devel pulseaudio pugixml-devel 
                libgme-devel
   sudo zypper install zlib-devel glew glew-devel glm-devel libpng-devel Mesa openal-soft-tools libogg- 
               devel alure-devel libvorbis-devel vorbis-tools libBox2D-devel libSDL2-devel libfreetype6 
               libffi-devel libX11-devel libXrandr-devel libXinerama-devel libgme-devel

Please start a topic on the forums if you are unsure or having problems with any dependencies your game needs.

Downloading Enigma

Enigma can be downloaded using the following git command:

   git clone git://github.com/enigma-dev/enigma-dev.git

Install IDE + Plugin

You will need to install the IDE LateralGM and ENIGMA plugin binaries; they can be installed 1 of 3 ways.

1) Running the install script in the enigma-dev folder:

  cd ~/enigma-dev
  ./install.sh

2) Invoking python via the python script:

  cd ~/enigma-dev
  python install.py

3) Or you can obtain manually per these instructions.

Additional Steps

OpenAL is the desired dependency for playing sound. However there are some codecs that may contain proprietary code, so Opensuse will not install them. One such file is the libdumb library. Other Linux distributions like Debian and Arch have such libraries. Opensuse however does not. For this reason you will get an error when you try to run a game with the OpenAL API selected. This can be fixed temporary with the reference to the 'dumb' library omitted. Doing so should be done as a last resort measure.

SFML is being proposed as an alternative to OpenAL via as an Extension. Based on its ease of use and integration in developing games and multimedia apps, it serves best as a simple interface to your pc components. It is composed of 5 modules: audio, network, window, graphics and system. You can find out more at its website SFML.org

To get SFML working you need to install the libsfml and sfml2-devel libraries.

Personal tools
Namespaces
Variants
Actions
Navigation
ENIGMA
Other
Toolbox