Pages: [1]
  Print  
Author Topic: LateralGM don't like me either :(  (Read 402 times)
Offline (Male) time-killer-games
Posted on: September 24, 2016, 05:17:51 PM

Member
Location: Virginia Beach
Joined: Jan 2013
Posts: 1064

View Profile WWW Email
Code: [Select]
Operating System: Windows 7
Version: 6.1
Architecture: x86

Java Name: Java HotSpot(TM) Client VM
Java Vendor: Oracle Corporation
Version: 1.8.0_101

Available processors (cores): 2
Free memory (bytes): 222217600
Maximum memory (bytes): 1013645312
Total memory available to JVM (bytes): 259522560

File system root: C:\
Total space (bytes): 500000878592
Free space (bytes): 420471885824
Usable space (bytes): 420471885824

File system root: D:\
Total space (bytes): 0
Free space (bytes): 0
Usable space (bytes): 0

File system root: E:\
Total space (bytes): 995721216
Free space (bytes): 665092096
Usable space (bytes): 665092096

Stack trace:

java.lang.Error: Invalid memory access
at com.sun.jna.Native.invokePointer(Native Method)
at com.sun.jna.Function.invokePointer(Function.java:470)
at com.sun.jna.Function.invoke(Function.java:415)
at com.sun.jna.Function.invoke(Function.java:315)
at com.sun.jna.Library$Handler.invoke(Library.java:212)
at com.sun.proxy.$Proxy0.definitionsModified(Unknown Source)
at org.enigma.backend.EnigmaSettings.commitToDriver(EnigmaSettings.java:247)
at org.enigma.EnigmaRunner$3.run(EnigmaRunner.java:208)
Logged
Offline (Male) time-killer-games
Reply #1 Posted on: September 24, 2016, 05:26:55 PM

Member
Location: Virginia Beach
Joined: Jan 2013
Posts: 1064

View Profile WWW Email
Also I tried updating Java to see if that would make any difference and in three different browsers (Chrome, Firefox, IE) when I click download I get:

Chrome:
Quote
Access Denied

You don't have permission to access "http://sdlc-esd-stage.oracle.com/ESD6/JSCDL/jdk/8u101-b13/chromeinstall-8u101.exe?" on this server.
Reference #18.1e080f17.1474755562.2427b9c

Firefox:
Quote
Access Denied

You don't have permission to access "http://sdlc-esd-stage.oracle.com/ESD6/JSCDL/jdk/8u101-b13/jxpiinstall.exe?" on this server.
Reference #18.9edc6068.1474755755.122e3c8b

IE:
Quote
Access Denied

You don't have permission to access "http://sdlc-esd-stage.oracle.com/ESD6/JSCDL/jdk/8u101-b13/JavaSetup8u101.exe?" on this server.
Reference #18.9edc6068.1474755926.1230356a

WTF? Am I the only one getting this? Check for yourself at:

https://www.java.com/en/download/

...and click the download button.

Thanks.
« Last Edit: September 24, 2016, 05:29:36 PM by time-killer-games » Logged
Offline (Male) Goombert
Reply #2 Posted on: September 25, 2016, 02:10:23 AM

Contributor
Location: Cappuccino, CA
Joined: Jan 2013
Posts: 3063

View Profile WWW
No, I just tried it myself and got the message too. I'm not sure if you would need to update Java or not, I don't think you do. Java 6 should work fine.

You really only need to have at least the minimum Java version we tell you to have on the download page. The reason is because we call various methods that are introduced in like Java 7. LGM is still supposed to start and run fine but if you click a button that uses some like Java 7 feature it will throw an exception. If you never run into the part of the program that uses that feature, you'll have no problem using it on really old Java versions. It's actually very clear what the error is when that happens too, because LGM shows its own message when you start telling you to update Java. So updating Java is not likely to fix this or other issues unless there happens to be a bug in the JVM causing your issue, which is sometimes the case.

Quote from: Oracle Website
Access Denied
You don't have permission to access "http://sdlc-esd-stage.oracle.com/ESD6/JSCDL/jdk/8u101-b13/JavaSetup8u101.exe?" on this server.

Reference #18.f578cae.1474787380.99c496e

Answer these questions please:
* Was this a fresh download of the portable ZIP?
* Were you trying to update an old portable with the new LGM and plugin? That may not work because there are changes on GitHub to the extension descriptors that means you need to pull from master.
* Did you try pulling from master but not updating LGM or the plugin?

If this was not a fresh download of the portable ZIP, please try download the fresh one from GitHub releases page.
https://github.com/enigma-dev/enigma-dev/releases
« Last Edit: September 25, 2016, 02:19:45 AM by Goombert » Logged
Offline (Male) time-killer-games
Reply #3 Posted on: September 25, 2016, 02:28:10 AM

Member
Location: Virginia Beach
Joined: Jan 2013
Posts: 1064

View Profile WWW Email
This should answer all of your questions - I downloaded the portable from github at that same link "fresh" and whatnot. This error happened. On the older portable it gave a different error which i do not have listed in this topic because i'd like to get the latest one working.
Logged
Offline (Male) Goombert
Reply #4 Posted on: September 25, 2016, 12:55:13 PM

Contributor
Location: Cappuccino, CA
Joined: Jan 2013
Posts: 3063

View Profile WWW
Show me the old error too because it might help.

Two more questions:
* So you did not modify the new ZIP in anyway?
* What is the full path to where you put the new ZIP?

Also, after you try running the old one, properly close it and do this.
1) Go to C:/ProgramData/ENIGMA and delete the whole ENIGMA folder.
2) Delete enigma-dev/compileEGMf.dll from the new ZIP.
3) Run the new ZIP from the exe again with administrative privileges by right clicking the file and selecting "Run as administrator"
Logged
Offline (Male) time-killer-games
Reply #5 Posted on: September 25, 2016, 02:02:57 PM

Member
Location: Virginia Beach
Joined: Jan 2013
Posts: 1064

View Profile WWW Email
- I did not modify it in any way
- C:\Users\Samuel\Desktop\ENIGMA\

I ran it as administrator in the first place so I don't see how deleting stuff and starting over will help anything.

There is only one user account on my laptop, and, you guessed it, it is "Samuel"...
Logged
Offline (Male) Goombert
Reply #6 Posted on: September 25, 2016, 11:09:36 PM

Contributor
Location: Cappuccino, CA
Joined: Jan 2013
Posts: 3063

View Profile WWW
Can you open git-bash and copy and paste the terminal to pastebin or something? Maybe you installed something that changed the environment path, I want to see it. I don't know how ENIGMA could just break sitting on your laptop for a period of time.
Logged
Offline (Male) time-killer-games
Reply #7 Posted on: September 27, 2016, 02:00:51 AM

Member
Location: Virginia Beach
Joined: Jan 2013
Posts: 1064

View Profile WWW Email
Can you open git-bash and copy and paste the terminal to pastebin or something? Maybe you installed something that changed the environment path, I want to see it. I don't know how ENIGMA could just break sitting on your laptop for a period of time.

May I slurp the slippery slime out of your ding dong?
Logged
Pages: [1]
  Print